Problems Connecting to S3A7 WiFi from Windows 10


#1

#NOTE: Upgrading the Smart Chef Demo binary to the Nov 23, 2016 version solved some of the problems, but there are still some connection issues

Get the updated binary here.

I’ve heard from both Medium One and Renesas that certain WiFi chipsets on Windows machines will not connect to the S3A7 for provisions. You should use your mobile phone for provisioning. Both Android and iOS work.

I’m successfully using a USB WiFi adapter with an Ralink 5370 chipset. It cost me $8.95. Windows 10 driver support is not listed on the site, but I have it working. There may be a better USB WiFi adapter with official Windows 10 support.

The problem occurs during the initial board configuration when the board goes into provisioning mode and becomes the hotspot and boots with a name like iot-wifi-KyWuJY.

I tried to connect to the board in provisioning mode from two different Windows 10 computers and failed to connect.

On the same day with the same S3A7 board, I was able to configure the S3A7 board in provisioning mode from these operating systems:

  • Windows 7
  • Ubuntu 16.10
  • Android.

To simulate a problem-solution scenario we might encounter at a meetup/workshop, I had my son go through the tutorial from Windows 10 and then use Android when he got stuck. He had to use Chrome on Android (his phone) to configure the board.

I’ve seen this problem before and saw it again tonight when my son hit the Windows 10 configuration wall. He couldn’t connect to 192.168.3.1 and could not get to the screen below.

The solution in my case was to use an Android phone and Chrome browser on Android to configure the S3A7 board. After configuration in provisioning mode, the board booted up cleanly and connected to my router. The rest of the Smart Chef Demo Quick Start Guide went smoothly.

During this time, I can connect to the board and ping it.

c:\Users\craig\Documents>ping 192.168.3.1

Pinging 192.168.3.1 with 32 bytes of data:
Reply from 192.168.3.1: bytes=32 time<1ms TTL=128
Reply from 192.168.3.1: bytes=32 time<1ms TTL=128
Reply from 192.168.3.1: bytes=32 time<1ms TTL=128
Reply from 192.168.3.1: bytes=32 time<1ms TTL=128

Ping statistics for 192.168.3.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

I get no data from an HTTP request, using both browser and curl.


Smart Fishtank Project Ongoing Build Log
S3A7 Smart Chef Demo with Environmental Sensor
Problems Configuring S3A7 API Keys From iPhone
Problems Connecting to S3A7 from Android